Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.


    MO LaTeX support is now powered by MathJax.

    Please report bugs or feature requests here.

    I'm not sure if this is a problem with MathJax, but when selecting "Render math in all pages, including the home page and questions pages" under prefs, I see blue underlines under the TeX in the question titles. The TeX in the titles on is much more nicely rendered.

    If it helps, I'm using Safari 5.0.1 on Mac OS X 10.6.4.
    • CommentAuthorJonas Meyer
    • CommentTimeAug 29th 2010 edited
    Nevermind. Harald Hanche-Olsen shows in the next comment how it works now. Thanks.

    Original post:
    This is sort of a feature request. I liked how I could double click on jsMath stuff and see the source, and that doesn't seem to work now. Is there a way we can get this back? For answers and questions, I can always view the source by going to the revisions list, but I can't do that for comments.

    @Jonas: Right click → Show source.

    • CommentAuthorWill Jagy
    • CommentTimeAug 29th 2010
    I can no longer see any processed Latex, MathJax says my browser is not supported (Firefox too early). Is there any way to tell it to use the previous setup? I know from trying that Firefox cannot be updated because of unmet dependencies involving library libc6, which I cannot install because the old apt-get won't do it, and so on and so on.

    @Anthony: I can't reproduce the blue underlines. Are they always there, or only when you mouse over the titles? When you say the TeX in titles on math.SE is more nicely rendered, do you mean that the fonts are actually different, or just the blue underline issue?


    @Will: One other person told me that he was having trouble with an old version of firefox. I've added a "(re)process with jsMath" link in the sidebar, but this is very much a temporary solution.

    • CommentAuthorWill Jagy
    • CommentTimeAug 29th 2010
    Thanks, Anton, that works. I need to do it twice, as I have for a few months anyway. There is no way around it, I need another computer with up to date Debian Linux, or unplug the one I have and have somebody who knows what they are doing put in current Debian, then current libraries and versions for a few dozen outdated facilities.

    Despite my wishes, computers are not furniture, I cannot allow mine to get too far behind the rest of the world.
    @Anton: Yes they were always there, not only when mousing over titles. It looks like it's been changed, so now, it's rendering exactly like the math.SE site. Yes, I meant the fonts were different. Before, it looked like it was rendering TeX in the titles as black bitmaps for each character with blue underlines, so that it wouldn't match the rest of the title, which is blue. For example. "On the R-algebra structure on C^\infty(M)," R would be rendered as a black \mathbb R with a blue underline, and more interesting, C^\infty(M) would be rendered in black fonts with a blue underline under C, a raised underline directly under \infty and another under (M). The rest of the title wouldn't be underlined until I moused over it. In any case, it looks like it's OK now.

    I need to do it twice, as I have for a few months anyway.

    Hmmm. My first thought was that the main jsMath file was taking a long time to load, so the 1 second delay I built in wasn't enough, but if you had to hit the old reprocess link twice, I have no idea what's going on.

    @Anthony: It must have been a caching issue. I haven't changed anything. I'm glad to hear it's better now.

    @Anton: I see, yes, thank you. That was it most likely.
    • CommentAuthorgrp
    • CommentTimeAug 29th 2010
    As a representative of the Neolithic age (IE 7.0), I am getting the message "Internet Explorer cannot load the page". If you want to follow up on XP/7.0 Windows systems, I will provide more detail and data. This post is primarily to encourage others to speak up who may have similar symptoms.

    Gerhard "My Dad's forebrain is bigger" Paseman, 2010.08.30 IST
    • CommentAuthorWill Jagy
    • CommentTimeAug 29th 2010
    Gerhard, that's ambiguous, are you saying that your dad's forebrain is bigger than that of my father or bigger than your forebrain? What's a forebrain?

    Anton made a temporary fix, very kind.

    The supported browsers are in a list here:

    When I click on the MathJax icon and first go to their site, for a moment there is a message in the lower left that says "Your browser is not supported by MathJax" or similar language, so these are not accidents or damage of any kind.
    Not a bug, but rather a complement! MathJax seems great so far! The old system (jsMath i guess?) routinely failed to rendor the tensor product symbol $\otimes$ on my browser of choice, Chrome
    on Ubuntu, and often messed up other symbols like capital $\Omega$, seemingly at random. It's really nice to see that these issues seem to be resolved by the switch to MathJax. Thanks!
    For the record, I have essentially identical problems to Will Jagy: an aging version of SeaMonkey not supported by MathJax on a computer I've been unable to upgrade, and the need to ask JsMath to process every page a second time.

    Thanks for the temporary solution. I will at some point (hopefully soon) get a new computer capable of supporting more modern software.
    • CommentAuthorvoloch
    • CommentTimeAug 30th 2010
    Font is too small on iPod.
    • CommentAuthorWillieWong
    • CommentTimeAug 30th 2010

    Filipe, if you right click on the formulae, you can set the "zoom trigger" to "hover" and "zoom factor" to something like "400%", then the math texts will appear magnified when you mouse over. (Then again, recalling that the IPod has this new fangled touch screen technology, I am not so sure whether what I just described is even feasible on it.)

    Also, does the math font not scale up the same as the text font?

    • CommentAuthorvoloch
    • CommentTimeAug 30th 2010
    Willie: I don't think I can right click on an iPod. The font scales as the surrounding text when you magnify but you end up with text off the screen and you need to scroll. When magnified it is clear that the math font is smaller than the text font, it's readable but looks funny.
    • CommentAuthorWillieWong
    • CommentTimeAug 30th 2010 edited

    Could it be a font/browser issue? I don't have access to a Mac to test at the moment. On Firefox/Linux, the $\mathrm{e}$-height and the "e"-height in normal text are the same. If anything I've found that the MathJax rendering is a bit wider (not sure about taller) than jsMath: a few equations that I edited to be less than the column width in jsMath now spills over.

    In anycase, too bad you cannot right click, because there's also the option (after right-clicking) to "scale all math" by a fixed percentage relative to the text. Unfortunately it seems that MathJax stores the settings in cookies, so I don't see an easy way for you to make a global setting easily without going through the menu.


    I confirmed the ipod problem this morning. It looks like math.SE has the same problem, but some inline math on looks okay, so maybe there's an easy way to fix it. I'll experiment a bit more tonight if I can get my hands on my wife's ipod. If somebody with an ipod confirms that this is a common problem on sites using MathJax, please post about it on the MathJax help forum

    Maybe this won't be considered a bug, but the way TeX got rendered on math overflow before this change was better than the way it's done now. It now looks the way "inline" TeX on Wikipedia looks. The TeX looks far bigger and bolder than the surrounding plain text.
    • CommentAuthorWillieWong
    • CommentTimeAug 30th 2010

    Not a bug, but a comment on what Michael Hardy reports: this definitely depends on font/browser/system.

    My work computer runs Firefox 3.5 over Scientific Linux, and as I reported above, the 'e' heights between mathmode and textmode are almost exactly the same, none of these "bigger, bolder" problems people seem to be having.

    Now that I am on my home computer, running Firefox 3.6.4 over Gentoo Linux, I found that the default setting leaves the inline math noticeably bigger than the surrounding text. I had to change the setting to scale all math down to 88% to improve things.

    (Before the switch to MathJax, I am pretty sure the two machines rendered the site in the same way using jsMath [no size discrepancy]. But seeing that I also just updated Firefox yesterday, I am not sure how much of this artefact is due to MathJax, and how much due to the new version of Firefox.)

    I am tempted to say that, insofar as size of the rendering goes, it may not be possible to please everybody.


    The “ipod” problem is quite clearly a problem on the iphone as well.

    Not only can you not “right click” on the idevice; you can't hover either, so you would have to set the maginfication trigger to click.

    It would probably be better to set a suitable magnification for math, though. I somewhat naïvely thought I could set math magnification to 150% on the laptop, then hoping that this setting would become associated with my account and magically become active on the iphone. But that seems not to be the case. All of which indicates that another way to open the math settings menu would be most welcome.

    • CommentAuthorWillieWong
    • CommentTimeAug 30th 2010

    @Harald: all the settings for MathJax are stored in cookies, which is why your attempt failed.

    Is it perhaps possible to just have two buttons on the side bar that triggers MathJax to change the current math scaling percentage by +/- 5%? This presumably requires some javascript-fu that I don't have. This may temporarily alleviate the problem for those underprivileged folks without right clicks. The fact that things are stored in cookies means that essentially you just have to set it once for each device you own, so a slightly clunky, incremental interface should not be too much of a hardship for the users.

    • CommentAuthortheojf
    • CommentTimeAug 30th 2010

    @Voloch: For right-click on the iPod, try clicking with two fingers at the same time. I haven't tried it myself, but this is something Mac is adopting at least for their laptop trackpads.

    @Anthony: I used to have that with jsMath, but got used to it.

    @Anton: I find that the default MathJax is rendering much too big on my regular old laptop (Firefox on Mac). I can right-click the correct the zoom factor, although the options are too many, and it takes some experimentation to figure out which of the many menus is the right one (Settings -> Zoom Factor does nothing, whereas Settings -> Scale All Math works). But actually I can also set it to MathML and be reasonably happy (again, Format -> MathML does nothing, whereas Settings -> Math Rendered -> MathML works). I think that eventually (or maybe it is already there) we should have a link to a how-to page on configuring MathJax. In any case, I like that I can chose whether to see it in MathML or CSS, and I also like that on Lynx everything just appears as raw TeX, which is easy enough to read.

    (I was recently talking to a math professor at University of Oregon, who complained that MO was completely unusable. It turns out that for perceived security reasons, he refuses to use javascript. I find MO in lynx usable but not excellent --- better than, say, the New York Times, worse than Google Search, about on par with gmail.)


    @theo: Right now the scaling of math is set to a default of 100%. For me, it looks too big in Chrome, but just right in Firefox, so I don't want to monkey with the defaults. It seems like inconsistent font size is a common issue.

    Format -> MathML makes so that you can get MathML source from Show Source.


    For right-click on the iPod, try clicking with two fingers at the same time.

    Uh, how would the idevice determine the click location? Remember, the idevices have no analogue of the mouse cursor.



    • CommentAuthorvoloch
    • CommentTimeAug 31st 2010
    Didn't expect it would work and indeed it doesn't. Two finger tap on idevice does nothing.

    It seems the only viable solution for touchscreen devices is that we try to insert buttons for "scale up maths" and "scale down maths" somewhere on the sidebar.

    Would this be too annoying or take up too much space? If so, we could possibly do this only for certain browsers, but that may be unnecessarily complicated.

    We should probably also bump this up to the MathJax developer.

    I'm having troubles where the mathrendering stops updating. I'll wait 5-10 seconds (looking at my watch), and MathJax hasn't altered in response to my edits. This can happen even when the most recent edits were in the text of my answer, not the mathematics. I don't know how to reliably replicate this, but it happened all the time when I was writing this answer .
    • CommentAuthoraxiomize
    • CommentTimeSep 2nd 2010
    Unfortunately, it doesn't seem to work on Konqueror (4.4.2, Ubunto 10.04)

    I get [Math Processing Error] instead of all math snippets, (I checked several pages, i.e. questions/answers on mathoverflow, there doesn't seem to be exceptions)

    The examples on

    work fine.

    Clicking the jsmath button (Reprocess with jsmath) at first doesn't do anything except showing the little jsmath icon on the bottom right of the browser. Selecting "reload" from the menu there at least gives me the source of the math snippets.

    • CommentAuthoraxiomize
    • CommentTimeSep 3rd 2010
    I have no idea why, but it seems to work now. (I did apply a security update...)
    OK so I'm going to ask here because I'll probably get a good answer quickly, even though there are probably other ways to proceed.

    So I am some dumb end user of MO, with no fancy browser or set-up, other than the fact that I use linux, and MO is currently almost unusable for me, and I don't know why. The problem isn't MO; I think it's MathJax. Here's what happens if I go to

    When I get there it says

    The Lorenz Equations


    The Cauchy-Schwarz Inequality

    [greyed out TeX]

    A Cross Product Formula

    [greyed out TeX]

    etc etc.

    30 seconds (I timed it) later the Lorenz equations appear (and they look beautiful) and the greyed out TeX for Cauchy-Schwarz magically disappears.

    30 seconds later Cauchy-Schwarz (the inequality itself, not the TeX source) appears and the greyed out TeX for the cross product formula disappears (and the formula appears 15 seconds later).

    It's the same viewing MO; I have to wait 20-30 seconds for each paragraph to TeXify.

    Standard debian linux set-up: debian 5.0.6, iceweasel 3.0.6

    Mozilla/5.0 (X11; U; Linux i686; en-GB; rv: Gecko/2010072023 Iceweasel/3.0.6 (Debian-3.0.6-3)

    A cursory glance through the mathjax docs produced nothing. My system is not remotely overloaded. Something is perhaps timing out? What have I done wrong?

    That is a bit odd. It looks like your version of xulrunner is fairly recent (1.9.0.x), so it probably shouldn't cause too much difficulty. I don't think the Iceweasel version should matter, but maybe you can try to upgrade to 3.5 or 3.6 branch?

    Also, I seem to remember the MathJax setup uses CSS to load fonts on the fly, I wonder in your case whether the bottleneck is at the network level (the loading of math fonts from the internet). Maybe use something like bwmon to check whether your network is saturated?

    Here I am on 1.9.2.x with firefox 3.6 over Gentoo and the entire test page that you linked to loaded within 15 seconds.


    I just had a go and while it wasn't as slow as yours, it was a bit slow (about 6-7 seconds for the first to appear, the others were slightly faster). So it may well be bandwidth as we're both in the same continent. If it is the downloading of the fonts then one possibility is to install the STIX fonts and change your MathJaX preferences to render as MathML. Then you get better looking output and faster as it doesn't have to download the fonts each time.

    (You have to set your preferences anew on each site, I think)

    I don't think it's bandwidth. The 30 second fiasco was occurring when I was at work with a superfast connection. I'm now at home on a much slower connection (usual UK broadband) and the first equation on the mathjax test page took about 6 seconds to render and the rest were pretty much instantaneous. I suspect my configuration at work is broken in some way, but given that debian straight out of the box is not _that_ willfully obscure it made me wonder whether I was not the only one with this problem.

    @WillieWong :I might try changing my browser; I'll download chrome tomorrow perhaps.
    • CommentAuthorgrp
    • CommentTimeSep 7th 2010
    I am noticing a couple of issues when mathjax renders (rerenders?) the question I have submitted on
    Erik Westzynthius's cool upper bound argument. My notation for P_n seems to clip the part of the P above the subscript n, so that it starts to look like F_n. The other more serious problem is that it resets the
    lines of text, so that some words are doubled across line breaks. Thus "in increasing order" becomes "in in increasing order" and "For such" becomes "For For such", with a line break between the repeated word.
    A refresh page command just reworks the page instead of redrawing. When I use jsmath, I get uglier fonts but the repeated word problem goes away. This is on Windows 7/IE 8 .

    Gerhard "No I'm not seeing DDouble" Paseman, 2010.09.07

    Any chance we could switch back to jsMath until some more quirks are worked out? Preview is completely and totally broken in Opera, and I understand that there are significant issues in Chrome as well.

    • CommentAuthortheojf
    • CommentTimeSep 10th 2010

    I'm very happy with MathJax, largely because I like MathML rendering better. (@Harry Gindi: there is the "reprocess math with jsMath" --- then again, it doesn't seem to do anything on my computer.)

    I have noticed two small bugs with the MathML renderer (I'm using Firefox on Mac). One is that in-line equations will break where they shouldn't --- TeX knows a lot about what symbols it can break next to and which ones it really shouldn't, and I wish MathML / MathJax did too. The other is that MathML in-line equations seem to make the spacing much too big around lines, so that especially if I have math on consecutive lines, it looks strangely double spaced. Part of the problem might be that I have "scale all math" set to 110%, but that extra 10% is not explaining as big a gap as I'm seeing.

    @Anton, if you can't reproduce this and want to see it, I can find you on Monday or something.


    While writing this answer, I found that $0<\alpha<n/p-1$ rendered as “0<α0”. Inserting a space, as in $0<\alpha< n/p-1$, cured it. Is it a MathJax/markdown interaction phenomenon? (The moment I asked this, I realized I could test it by placing backticks around the formula. And indeed, with backticks it works fine without the extra space.)


    The '<n' is getting interpreted as the start of an HTML tag and so is being sanitised by the SE software. Putting the space in breaks the match (since tags must start '<[a-z]'), putting it in code also breaks the match since the '<' gets converted to an entity before being processed.

    (This is the sort of thing one should expect when running two formatters that don't integrate. I know that there's not a lot that can be done about that, but that doesn't stop me living in hope.)

    (Seeing it written down is what gave me the clue, Harald. When you told me of this, I didn't visualise it so didn't spot it!)

    • CommentAuthorjc
    • CommentTimeSep 29th 2010

    In relation to Gil Kalai's question I found that "less than" symbols can be made to work if you put curly brackets around them like so {<}.


    jc, that's because that also doesn't match the XHTML tag pattern. So any "NOP" after the < will do (but a } is only a NOP if there's a matching { before)


    In TeX there is a big difference between < and {<}: The former is a relation, the latter is an ordinary math symbol and thus lacks the spacing that would surround a relation symbol.

    • CommentAuthortheojf
    • CommentTimeOct 3rd 2010

    I think there is a bug with the MathML rendering of operator names from MathJax. When I write "$\pmod 2$", for example, I should see something approximating "(mod 2)", whereas MathML (but not, it memory serves, the Javascript renderer) prints it as closer to "(m o d 2)". What's going on, I think, is that MathJax is incorrectly coded to conflate the commands "\rm" and "\operatorname". Now, the correct behavior for "$\rm{mod} 2$" is to print "m o d 2" (let's assume you've already coded the parentheses): the space in "$\rm{mod} 2$" is spurious, and clearly I am asking for the product of four terms, "m", "o", "d", and "2", and I am asking that the m,o,d be printed in roman. Operatornames, on the other hand, should be printed as words, not products. (I'll note that TeX does not add small spaces between letters in a product --- you only notice that it thinks about products and words differently by observing the handling of ligatures.)

    I'm experiencing an issue with font sizes of tex in <code> blocks. This occurs in Chrome, but does not in Firefox. I chased it down to a statement "font-size:56%" buried in the css. Deleting this statement restores the math to the expected size. Please see the image below

    I'm using Chrome 7.0.517.24 beta on Ubuntu 10.04.

    The recent update of Chrome on Ubuntu 10.04 has broken math rendering on MathOverflow. Currently I see blank spacing whenever someone enters math mode. Here's an example (click for big):

    This is with Chrome 7.0.517.36 beta on Ubuntu 10.04. Firefox on Ubuntu works fine.


    Pages that have a lot of TeX run incredibly slowly for me when I use IE 8.


    @Qiaochu: I was going to quip “don't do that, then”, but then I thought this might start a flamefest, so I shall restrain myself.